Me faltan opciones en la edición de los enlaces

Home Forums Desarrolladores / Desenvolupadors / Garatzaileak / Desenvolvedores / Developers Me faltan opciones en la edición de los enlaces

This topic contains 14 replies, has 2 voices, and was last updated by  rluna 3 months, 2 weeks ago.

  • Author
    Posts
  • #27133

    rluna
    Member

    En TinyMCE4 no aparecen las pestañas ventana emergente, efectos y avanzado.
    Estuve buscando y veo que algunas opciones se encuentran desde el menú Editar → Editar/insertar atributos pero, en general, se ve uno obligado a insertar los códigos desde el editor HTML.
    Al usuario medio se le dificulta mucho la apertura de pop-ups y la creación de efectos lightbox que resultan muy cómodos con TinyMCE3.

  • #27138

    Ignacio Gros
    Member

    Gracias, Raúl.

    Abro petición en GitHub: https://github.com/exelearning/iteexe/issues/153

  • #28128

    Ignacio Gros
    Member

    Hola Raúl.

    He añadido todo lo que sugerías. Son varias novedades, y están en un punto bastante delicado (esa parte no debe fallar). Como falta poco para lanzar una versión de eXe que incluiría esas mejoras, estaría bien probarlas lo más posible.

    En https://github.com/exelearning/iteexe/issues/153 encontrarás el zip con la nueva versión de TinyMCE completa. Si tienes tiempo y pruebas nos vendría muy bien. ¿Me avisas si encuentras algún fallo?

    Gracias por todo.

    • #28131

      rluna
      Member

      Hola Ignacio. Te respondí en un mail por fuera. Algo debí hacer mal al sustituir porque no me aparece caja para editar además de alguna cuestión de visualización que te comento con un par de capturas.
      Comento por si alguien tiene una pista: lo que hice fue eliminar la carpeta original /usr/share/scripts/tinymce_4 y copiar la nueva dándole permisos 755 a la misma y a las subcarpetas.
      Un abrazo

  • #28132

    Ignacio Gros
    Member

    Perdona, Raúl.

    Prueba a sustituir tinymce_4_settings.js también. Lo dejo GitHub: https://github.com/exelearning/iteexe/issues/153

    ¿Funciona?

    ¡Gracias!

    • #28133

      rluna
      Member

      Nada. Cambié tinymce_4_settings.js y revisé también los permisos de archivos para comprobar que estaban en 644 como anteriormente y sigue igual.
      Volví a restaurar la versión antigua y los settings y todo vuelve a funcionar, con los errores que ya conocíamos obviamente. Voy a probar en una máquina virtual con windows a ver qué pasa.
      La seguimos.

    • #28134

      rluna
      Member

      Probando en una máquina virtual con W10. Instalación limpia. Sustituyo versión y settings y parece que funciona.
      Voy a aprovechar para hacer comparación en paralelo con la versión anterior en Linux y así voy viendo todas las diferencias y probando que funcionan.
      Voy contando si encuentro algo raro.

    • #28141

      rluna
      Member

      Hola Ignacio:
      ¡¡¡También funciona en Ubuntu!!!. Había sido un error mío que en vez de sustituir los settings lo dupliqué (no me preguntes cómo pero fue eso). Lo descubrí revisando los cambios que había registrados en github al ver que no estaban en el archivo que tenía. Disculpas por el susto :-/
      Aprovecho para plantear una sugerencia: cuando pones encabezado y/o pie se genera automáticamente un div que tiene la clase position-center y un ancho nullpix que engloba a los div con clase figcaption y header a los que les afecta también la alineación.
      Eso funciona perfecto cuando se mantiene la alineación centrada de la imagen, pero si se cambia a la izda o derecha también desaparece la alineación centrada respecto a la imagen de la cabecera y el pie.
      ¿Se te ocurre algún cambio para que una vez que la imagen está situada a izda o dcha se pueda volver a situar los encabezados y pies centrados respecto al tamaño de la imagen y no al ancho total de la página? Supongo que utilizando posiciones relativas y haciendo que el div que incluya cabecera, imagen y pie tenga una medida determinada podría servir… aunque le veo la dificultad de que si la imagen no es muy ancha pueden romperse en más de un renglón y, por otra parte, supongo que afectará negativamente a la visualización responsive. En fin, una propuesta por si se te ocurre alguna idea.
      Un abrazo.

  • #28135

    Ignacio Gros
    Member

    Muchas gracias, Raúl. En master funciona como lo estás viendo en Windows.

    Buen fin de semana :-)

    • #28136

      rluna
      Member

      Por aquí todavía tenemos cinco horas menos, así que aún me queda un rato para el fin de semana. Te voy contando lo que encuentro:

      1. Se generan bien los lightbox desde el desplegable en el menú de enlaces
      2. No me toma las imagenes svg, ni en los lightbox ni como imagen.
        • En el lightbox me avisa (en inglés) Image cannot be loaded. Make sure the path is correct adn image exists. Si escribo el código del lightbox con la versión anterior la imagen se muestra sin problema.
        • Si simplemente incluyo una imagen no la muestra. En la versión anterior si se muestra.
      3. Ventanas emergentes → Funciona
      4. Eventos → funciona
      5. Imagen campo title → aparece el campo en el menú emergente y funciona.
      6. Imágenes encabezado y titulo al pie → funcionan. Sugerencia cambiar el literal Título de la imagen por Pie de imagen y Enlace del título por Enlace del pie
      7. Imagen alineaciones → funcionan las verticales (¿no son redundantes arriba y Texto arriba y abajo y Texto abajo?) pero las horizontales no van porque traducen el atributo por vertical-align en vez de float.
      8. Imagen → Faltan los bloques intercambiar imagen y misceláneo que sí aparecen en TinyMCE3 dentro de la solapa Avanzado.

      Si encuentro algo más te cuento. Buen fin de semana.

    • #28146

      Ignacio Gros
      Member

      Muchas gracias, Raúl. Revisaré todo lo antes posible. Te aviso.

    • #28147

      Ignacio Gros
      Member

      Hola Raúl.

      Contesto a los puntos pendientes:

      • El problema de los SVG se debe resolver desde el servidor (desde eXe). Parece que no se muestran porque no se sirven como imagen, sino como texto. Al exportar sí se ven bien. Abro incidencia para solucionarlo: https://github.com/exelearning/iteexe/issues/194
      • En los exportados tampoco se veía el SVG dentro de Lightbox en algunos navegadores, para los que la imagen mide 0x0. Eso se resuelve dándole un tamaño por defecto (he elegido 450×450). La imagen conservará sus proporciones. El fichero exe_lightbox.js con los cambios está en el zip adjunto.
      • Lo de poner “Título de la imagen” en lugar de Pie es porque al permitirse la cita completa (título de la obra, autor, enlaces a los mismos y licencia) se consideró más claro llamarlo así, porque el pie engloba todo eso. De todas formas aviso a @jrfern, que como sabes ha trabajado mucho en los textos y sus traducciones. Yo me quedaría con la opción actual.
      • Creo que las alineaciones verticales no son redundantes, porque “top” y “text-top” no son exactamente lo mismo, e igual con “bottom” y “text-bottom”. Más información en https://www.w3schools.com/cssref/pr_pos_vertical-align.asp
      • Muchas gracias por avisar del problema con “float”. Ya está resuelto. Adjunto los cambios.
      • Le he estado dando vueltas a la opción de intercambiar imagen. Es cierto que ha desaparecido, pero también creo que eXe debe facilitar la inserción de contenido accesible, y sustituir una imagen “onmouseover” tal y como permite TinyMCE 3 en eXe presenta problemas de accesibilidad. Si se quiere, por ejemplo, mostrar los resultados (se ve por defecto la imagen sin resultados), creo que es mejor usar otra solución, como un Lightbox, o incluso mostrar los resultados en la retroalimentación del iDevice. De todas formas, sí se podría recuperar el comportamiento. Lo comentamos y te aviso si hay cambios.

      Muchas gracias por las pruebas y tantas buenas sugerencias.

      Archivos adjuntos:

      You must be logged in to view attched files.

    • #28149

      rluna
      Member

      Hola Ignacio:
      Muchas gracias por la info sobre las diferencias entre top y text-top.
      H5P acaba de sacar el contenido Agamotto que es una interesante alternativa para mostrar capas de información.
      Probado y funcionando la inclusión de svg.
      Un abrazo.

  • #28168

    Ignacio Gros
    Member

    Hemos comentado lo de intercambiar imagen y se ha decidido no hacerlo para facilitar la creación de contenidos accesibles. Como sabes, en muchos casos es una obligación, y en todos algo a tener muy en cuenta.

    Para el pie de foto he subido el cambio que puedes ver en la imagen adjunta. La cadena aparecerá traducida, claro.

    Dejo lo de H5P para más adelante :-)

    ¡Gracias, Raúl!

    Archivos adjuntos:

    You must be logged in to view attched files.

  • #28172

    rluna
    Member

    Muy buena la alternativa para el pie de imagen porque deja claro dónde va a aparecer la información que se introduce.
    Comparto la importancia de la accesibilidad, así que también me parece acertada la decisión respecto a las imágenes intercambiables.
    Lo de H5P puede venir bien como fuente para de ideas para alguna funcionalidad que se pueda considerar especialmente interesante, pero tampoco tiene sentido cargar exe cuando se pueden utilizar los recursos embebiéndolos.
    Un abrazo

You must be logged in to reply to this topic.