problemas con formularios incrustados de Google Drive

Home Forums Ayuda / Ajuda / Laguntza / Axuda / Help problemas con formularios incrustados de Google Drive

This topic contains 3 replies, has 2 voices, and was last updated by  Ignacio Gros 1 month, 1 week ago.

  • Author
    Posts
  • #29184

    grubiona
    Member

    Hola:

    Los formularios de Google incrustados en un proyecto Exelearning que luego se ha exportado (como HTML .zip) a un Sakai dan error a menudo (no en todas las versiones de Firefox, y en alguna de Chrome) y no se pueden rellenar los campos del formulario. El formulario se ve, pero no se puede rellenar ningún campo. Me lo están reportando algunos alumnos y yo puedo reproducir el error en mi ordenador. Lo curioso es que parece que hay quien puede y quien no.

    Además, con los enlaces a documentos Drive desde el mismo proyecto exportado a Sakai me sale esto: “A browser error has occurred. Please hold the Shift key and click the Refresh button to try again.” Esto pasa en Firefox.

    He estado mirando en los foros y no acabo de encontrar una respuesta. No parece que sea el sitio Sakai el que bloquee, aparentemente es el navegador pero si hago el preview del proyecto en localhost entonces no tengo error. Es decir, el error solamente me da desde la exportación que he alojado en Sakai.

    ¿Alguna pista, por favor?

    Gracias de antemano!!

  • #29191

    Ignacio Gros
    Member

    He probado en dos servidores (no con Sakai) y no he tenido problemas para rellenar el formulario.

    ¿Puedes pasarnos un enlace, por favor?

  • #29194

    grubiona
    Member

    Hola:

    Sí, te voy a crear un usuario para que puedas entrar al Sakai y reproducir desde ahí el problema, a ver si te pasa.

    ¿Puedes darme un correo electrónico para pasarte el usuario y la contraseña?

    Muchas gracias,

    Gabriel

    • This reply was modified 1 month, 1 week ago by  exelearning. Reason: Eliminar dirección de correo
  • #29239

    Ignacio Gros
    Member

    Hola Gabriel.

    Te contesto aquí en lugar de por correo por si alguien tiene un problema parecido y le sirve la respuesta.

    El fallo que da es éste:

    Solicitud desde otro origen bloqueada: la política de mismo origen impide leer el recurso remoto en https:// […] gstatic.com […] (razón: falta la cabecera CORS ‘Access-Control-Allow-Origin’).

    Aquí tenéis más información: https://developer.mozilla.org/es/docs/Web/HTTP/Access_control_CORS

    Lo mejor es que se lo comentes a quienes administran vuestro servidor para que intenten solucionarlo con PHP o mediante el fichero htaccess. Desde el contenido generado con eXe no se puede hacer nada.

    Otra opción es usar un enlace en lugar de un IFRAME para abrir el formulario, claro.

    Espero que podáis solucionarlo.

You must be logged in to reply to this topic.