Bug en el selector de color

Tagged: 

This topic contains 21 replies, has 5 voices, and was last updated by  Rafael Vidal 7 years, 9 months ago.

  • Author
    Posts
  • #492

    Rafael Vidal
    Participant

    Hola:
     
    Cuando se seleccionan colores, en la ventana Seleccionar color, en la pestaña Selector se queda siempre el valor negro. Versión 3605intef6 en XP, Windows 7 y Mac.
     
    Un saludo

  • #554

    Ignacio Gros
    Member

    Por favor, dinos en qué ventana exactamente (¿En TinyMCE? ¿En qué iDevice?) para poder comprobarlo.
    También vendría bien saber qué estilo se está utilizando (por si acaso el fallo está relacionado con eso).
    Gracias.

  • #586

    Rafael Vidal
    Participant

    Hola:
     
    En todos los idevices que he probado, text libre, actividad ee lectura, rellenar huecos,…. y con distintos estilos.  Adjunto un pantallazo.
     
    Un abrazo

    Attachments:
    You must be logged in to view attached files.
  • #723

    Ignacio Gros
    Member

    Solucionado: https://forja.cenatic.es/tracker/index.php?func=detail&aid=1441&group_id=197&atid=883
    Adjunto el fichero modificado por si queréis probarlo (ubicación: scripts\tinymce\jscripts\tiny_mce\themes\advanced\jscripts\color_picker.js).
    Guardad copia del anterior por si hubiese algún problema.
    Hay varios fallos de este tipo que se resolverán en cuanto podamos utilizar la última versión de TinyMCE.

    Attachments:
    You must be logged in to view attached files.
  • #772

    Probada solución intef6.1 sobre ubuntu 12 y funciona la selección de color.

    Cosas nuevas del tiny: (al menos que observo en 6.1)

    No se previsualizan los cambios en el tamaño del texto (en el código html están bien definidos) Muestro vídeo

    No funcionan bien los anchos de las tablas (adjunto vídeo) https://www.dropbox.com/s/amnmre47r4zufv5/video01.zip

  • #779

    Ignacio Gros
    Member

    Hola Antonio: lo voy mirando, pero no he podido descomprimir el zip (ni en XP, ni en Ubuntu…).

    ¿Lo puedes revisar?

    Gracias.

  • #780

    Ignacio Gros
    Member

    La primera parte (“No se previsualizan los cambios en el tamaño del texto”) está resuelta (incidencia 1445).
    Adjunto extra.css a incluir en la carpeta “css” del directorio en el que tengas eXe por si quieres probar la solución.
    El código es para la versión intef6.1 de eXeLearning.

    La segunda parte (“No funcionan bien los anchos de las tablas”) no he conseguido reproducirla. He creado una tabla con ancho fijo y ha funcionado bien en todos los casos que he probado. Lo volveré a mirar cuando tenga el vídeo.

    Saludos.

    Attachments:
    You must be logged in to view attached files.
  • #782

    Vídeo 1: https://www.dropbox.com/s/bkpgiedze2q93rf/uno-1.ogv

    Vídeo 2: https://www.dropbox.com/s/j57scrtuqr9lk8z/uno-2.ogv

    Pruebo en un momento la solución y te digo

    Gracias Ignacio

  • #783

    Ignacio Gros
    Member

    El archivo uno-2.ogv sólo pesa 84 KB. No consigo ver nada. ¿Puede estar vacío?

    Gracias.

  • #784
  • #792

    Ignacio Gros
    Member

    Gracias, Antonio.

    Abierta incidencia (1447)

    Ya está arreglado.

    Si quieres probar la solución, descarga el zip adjunto.

    El archivo .js va en scripts\tinymce\jscripts\tiny_mce\plugins\table\jscripts\table.js (es para intef6.1).

    Saludos.

    Attachments:
    You must be logged in to view attached files.
  • #796

    Probado con éxito tanto la solución de las tablas como la del tamaño del texto. ENHORABUENA

    Funciona correctamente intef6.1 ubuntu 12

    Por favor, para llevar control apuntemos estos cambios para la siguiente revisión que hagamos ok? 

    Saludos

  • #797

    Otra cosilla mas que he detectado ahora. La opción de alinear las imágenes “Absolute Middle” no funciona ¿También es de Tiny?

  • #803

    Ignacio Gros
    Member

    Es que esa opción añade esto al código en la previsualización: align=”absmiddle”.

    Y el editor (por su configuración o porque ésta no es completamente compatible con todos los plugins) no guarda todo el código necesario.

    En el editor de eXe, por ejemplo, align=”absmiddle” no está permitido, pero el plugin no genera el CSS equivalente para incluirlo en la etiqueta style, de manera que al guardar se pierde el cambio.

    Ya he empezado con el paso a TinyMCE 3.x. En cuanto sepa cuándo podría estar lista os aviso. Si es pronto, tal vez no merezca la pena intentar resolver esos fallos. Muchos de ellos, si no todos, estarán resueltos en la nueva versión. No suelen ser fallos difíciles de resolver, pero a veces se tarda un poco en dar con el punto en el que se producen.

    ¿Esperamos a ver si la actualización es sencilla antes de intentar resolver ese fallo?

  • #804

    Si, esperamos a ver cuando puede estar lista la actualización a TinyMCE 3.X y a partir de ese momento decidimos.

     

  • #822

    Ignacio Gros
    Member

    Es un problema parecido al comentado en “Bug con Latex“.

    La configuración actual de TinyMCE elimina el valor “absmiddle” del atributo “align” de la imagen porque no está en la lista de valores permitidos (no es XHTML válido).

    Solución a éste y otros problemas similares: que TinyMCE acepte todo.

    Se habló de esto en la reunión del equipo de desarrollo. Algunos éramos partidarios de que TinyMCE aceptase todo y, más adelante, permitir al usuario elegir (desde la propia interfaz de la aplicación) si quiere un editor más o menos restrictivo.

    Solución a este problema: permitir ese valor para el atributo “align”. Ese código que no valida se acepta, pero otros no. No se podría insertar una etiqueta “embed”, por ejemplo.

    El cambio sería muy rápido.

    ¿Se acepta todo, “absmiddle” o se deja como está?

  • #825

    Ignacio Gros
    Member

    Completo el mensaje anterior:

    • Otra forma de solucionar este problema es ocultar en el plugin las opciones “baseline”, “texttop”, “absmiddle” y “absbottom”.
    • Los valores válidos son “top”, “middle”, “bottom”, “left” y “right”.
    • Lo malo es que si alguien tiene alguno de esos valores en su elp, y lo edita con TinyMCE, el editor lo borrará.
  • #828

    Ignacio Gros
    Member

    Solucionado (incidencia 1448: TinyMCE – La opción de alinear las imágenes “Absolute Middle” no funciona).

  • #829

    Muchas gracias Ignacio

  • #1592

    jrfern
    Member

    Administrador, el ruso no es una lengua oficial de este foro, ¿verdad? Además, estos posts tienen una pinta de spam… Sugiero borrado inmediato y baja del autor..

The topic ‘Bug en el selector de color’ is closed to new replies.