Problema con Firefox 17.0

Tagged: 

This topic contains 41 replies, has 16 voices, and was last updated by  Antonio Monje Fernández 7 years, 6 months ago.

  • Author
    Posts
  • #1685

    He estado usando la última versión disponible de EXEintef6.2 en Ubuntu 12.04 y 10.04 sin problemas con firefox 16..

    Acabo de actualizar firefox as la versión 17 en ubuntu 12.04 y al abrir un proyecto de exe las opciones de exportación y guardado no funcionan. Ni siquiera puedo salir de EXE desde el menú archivo. Aparece el siguiente error cuando intento salir la primera vez:

    “Exception: TypeError: netscape.security.PrivilegeManager is undefined Caused by script:doQuit()”

    Alguna solución?

    Gracias.

  • #1756

    Ignacio Gros
    Member

    He actualizado a FF 17 en Windows Vista y no he tenido ese problema. De todas formas, lo comprobaremos en otros SO. Tal vez sería suficiente con comprobar si esa función existe antes de intentar ejecutarla:

    if (typeof(netscape.security.PrivilegeManager)!=’undefined’) netscape.security.PrivilegeManager…

    Avisamos en cuanto lo sepamos son seguridad.

    Gracias por el aviso.

  • #1757

    Ignacio Gros
    Member

    Sí. Falla en Ubuntu. Y solucionado el fallo de netscape.security.PrivilegeManager salen otros. Lo miramos. Muchas gracias.

  • #1769

    pedro.pena
    Member

    Hola,

    Es un problema bastante grave para eXe. Mozilla ha decidido quitar completamente la función enablePrivilege de su api (https://developer.mozilla.org/en-US/docs/Bypassing_Security_Restrictions_and_Signing_Code). En eXe se usa intensivamente esta función para poder operar con archivos locales, así que habría que migrar esa funcionalidad al nuevo modelo que propone Mozilla. Esto será costoso y estamos estudiando si merece o no la pena, ya que la siguiente versión posterior a intef6.3 ya no dependerá de Firefox.

    De momento la única solución rápida es volver a una versión anterior de Firefox. La pega es que por ejemplo en Ubuntu, Firefox 16 no está visible en sus repositorios. Sin embargo físiscamente siguen estando en http://archive.ubuntu.com/ubuntu/ubuntu/pool/main/f/firefox/.

    Un saludo.

  • #1773

    Gracias Pedro, tengo el mismo problema y he llegado al repositorio, pero me he vuelto loco. Cual(es) es/son los archivos que hay que bajar para instalar firefox 16? He empezado un poco a ciegas y he pensado que es mas intelegente preguntar que meter la pata hasta el fondo. Estoy deseando que llege la nueva versión y nos libremos de la obligatoriedad de usar firefox.  Muchas gracias a todos y todas por el trabajo que estais haciendo.

  • #1774

    ljrodero
    Member

    Yo ya he desinstalado la 17 y he vuelto a instalar la 16. Los enlaces son: http://archive.ubuntu.com/ubuntu/ubuntu/pool/main/f/firefox/abrowser-branding_16.0.2+build1-0ubuntu0.12.04.1_i386.deb y http://archive.ubuntu.com/ubuntu/ubuntu/pool/main/f/firefox/firefox-locale-es_16.0.2+build1-0ubuntu0.12.10.1_i386.deb (si tienes ubuntu 12.10; si es otra versión solo hay cambiarla en el nombre de los dos archivos). Para instalarla he usado la terminal (dpkg -i <nombre archivo>), ya que desde el Centro de Software no me funcionaba.

    ¿Para cuándo se calcula que pueda estar la versión 6.3?

  • #1775

    pedro.pena
    Member

    Hola,

    Ubuntu 10.04 i386: http://archive.ubuntu.com/ubuntu/ubuntu/pool/main/f/firefox/firefox_16.0.2+build1-0ubuntu0.10.04.1_i386.deb

    Ubuntu 10.04 amd64: http://archive.ubuntu.com/ubuntu/ubuntu/pool/main/f/firefox/firefox_16.0.2+build1-0ubuntu0.10.04.1_amd64.deb

    Ubuntu 12.04 i386: http://archive.ubuntu.com/ubuntu/ubuntu/pool/main/f/firefox/firefox_16.0.2+build1-0ubuntu0.12.04.1_i386.deb

     

    Ubuntu 12.04 amd64: http://archive.ubuntu.com/ubuntu/ubuntu/pool/main/f/firefox/firefox_16.0.2+build1-0ubuntu0.12.04.1_amd64.deb

     

    Ubuntu 12.10 i386: http://archive.ubuntu.com/ubuntu/ubuntu/pool/main/f/firefox/firefox_16.0.2+build1-0ubuntu0.12.10.1_i386.deb

     

    Ubuntu 12.10 amd64: http://archive.ubuntu.com/ubuntu/ubuntu/pool/main/f/firefox/firefox_16.0.2+build1-0ubuntu0.12.10.1_amd64.deb

     

    Como bien dice jrodero hay que descargar el paquete e instalarlo desde terminal mediante “sudo dpkg -i <nombre_de_paquete>”. Desde el Centro de Software no nos deja hacer downgrade, al menos en 12.04, donde he probado.

    La versión intef6.3 todavía estará basada en interfaz XUL (o sea depende de firefox) y por tanto seguirá teniendo el mismo problema. Seguramente mañana pondremos a disposición del equipo de probadores una versión candidata a final. Cuando pase el corte del equipo de probadores se publicará.

    No será hasta intef7 que podremos librarnos de XUL e independizarnos del navegador. Con esa versión Firefox >=17 volverá a funcionar. De momento no hay fecha prevista, pero podríamos pedírsela a Papá Noel o a los Reyes. Los mismo cae.

     Un saludo.

  • #1779

    saorin
    Member

    Las descargas indicadas de firefox 16 para Ubuntu 10.04 no funcionan. Para Ubuntu 10.04 es mejor la dirección

    https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa/+build/3929668

    Después de desinstalar la versión 17

    Descargamos e instalamos los paquetes

    firefox_16.0.2+build1-0ubuntu0.10.04.1_i386.deb

    firefox-locale-es_16.0.2+build1-0ubuntu0.10.04.1_i386.deb

    firefox-gnome-support_16.0.2+build1-0ubuntu0.10.04.1_i386.deb

  • #1783

    Estoy impaciente por ver la intef7 sin depender del firefox. Yo se lo pido a los Reyes, jeje.

    Mis felicitaciones al equipo de desarrollo que esta haciendo un gran trabajo.

    Un saludo.

  • #1790

    rluna
    Member

    ¿Y los que tenemos 12.10?. Al parecer se ha detectado un error de seguridad grave en FF 16.02 y ya no está disponible. ¿Hay alguna forma de poder hacer un downgrade a la FF15? Si no lo consigo pocas pruebas voy a poder hacer de la próxima version 🙁

    Un abrazo

    Raúl

  • #1792

    pedro.pena
    Member
  • #1797

    rluna
    Member

    ¡Gracias Pedro! Ya vuelve a funcionar el eXe. 

    A ver si es verdad que los reyes nos traen una versión independiente del FF para evitarnos estos sustos

    Un abrazo

  • #1799

    Hoy ya ha salido la carta.

    Metida en el buzón, certificada, urgente y rumbo a oriente… como nos hemos portado todos bien… esperemos que no nos traigan carbón!!!!

    Salud

  • #1824

    Rodrigo
    Member

    Tengo el mismo problema, pero no sé si por mi ignorancia acerca del manejo del terminal o por alguna otra cuestión, no consigo instalar los paquetes de firefox. Mi versión de ubuntu es la 12.04. Cuando intento instalar alguno de estos paquetes (firefox_16.0.1+build1-0ubuntu0.12.04.1_i386.deb o firefox-dev_16.0.2+build1-0ubuntu0.12.04.1_i386.deb) siguiendo vuestras instrucciones, me aparece un mensaje de ‘error al procesar’ (os envío un pantallazo para que veáis la secuencia completa).

    Agradecería cualquier ayuda (estoy inmerso en un proyecto educativo para la Xunta de Galicia y se me acaba el tiempo…).

    Un saludo.

    Rodrigo

    Attachments:
    You must be logged in to view attached files.
  • #1826

    pedro.pena
    Member

    Hola,

    Fíjate que el paquete que estás instalando no es correcto (empieza por firefox-dev). En tu caso prueba con éste: https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa/+files/firefox_16.0.2%2Bbuild1-0ubuntu0.12.10.1_i386.deb.

    Un saludo.

  • #1827

    Rodrigo
    Member

    Gracias por la rápida respuesta, pero acabo de probarlo y sigue sin funcionarme… Aparece el mismo mensaje de antes: adjunto un pantallazo… No sé qué puede ir mal.

    Gracias de antemano por cualquier sugerencia…

     

    Attachments:
    You must be logged in to view attached files.
  • #1829

    pedro.pena
    Member

    Por el error, parece que tienes que desplazarte primero al directorio donde hayas descargado el paquete deb (seguramente Descargas).

    Un saludo.

  • #1830

    Rodrigo
    Member

    Perdona mi torpeza, pero no sé a qué te refieres: ¿Cómo tengo que hacer eso de desplazarme al directorio de descargas (en efecto, es aquí donde tengo el paquete deb)?

    Un saludo

  • #1833

    jesusdeyarza
    Member

    Hola a todos y gracias por vuestro increíble trabajo!

    Me pasa como a Rodrigo, al descargarlo desde la terminal me da un error pues no encuentra el archivo en el servidor. En el repositorio de firefox que señala Pedro al principio del foro no aparece ninguna versión del ff 16.02 para ubuntu 12.04. He descargado la versión 16.02 para ubuntu 11.04, pero al abrir inmediatamente firefox me aparece actualizado a la versión 17 (como si lo actualizara automáticamente)… 

    A ver si me podéis echar un cable con esto… gracias, de nuevo, por vuestro trabajo de desarrollo y de mejora… en las sociedades modernas, sois como los brujos del poblado pues soís capaces de hablar con el más allá (el otro mundo para los que no programamos), je, je

    Un saludo

    Jesús

     

     

  • #1835

    pedro.pena
    Member

    Hola,

     

    Ejecuta primero “cd Descargas”.

    Y luego prueba a instalar con el comando que estabas ejecutando.

     

    Un saludo.

  • #1836

    pedro.pena
    Member

    Hola,

    Efectivamente, en el enlace que puse primero, han quitado la versión 16.02. Puse otro enlace que apuntaba a launchpad, en el que sí siguen funcionando.

    Concretamente para 12.04 i386 sería: https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa/+files/firefox_16.0.2%2Bbuild1-0ubuntu0.12.04.1_i386.deb

     

    Un saludo.

     

  • #1837

    Rodrigo
    Member

    Hola.

    Problema solucionado (creo…). ¡Muchísimas gracias por vuestro trabajo! Sobre todo a ti, Pedro. Por la rapidez en responder y por las aclaraciones constantes a nuestras dudas.

    Un saludo.

  • #1838

    jesusdeyarza
    Member

    Hola Pedro,

    gracias por tu rápida respuesta… Al descargar el archivo y ejecutarlo, me manda al repositorio de ubuntu, y en lugar de darme la posibilidad de instalarlo me manda el mensaje que puedes ver en el pantallazo que te adjunto. 

    saludos

     

     

    Attachments:
    You must be logged in to view attached files.
  • #1840

    Hola Jesús:

    Tienes que instalarlo por terminal (haciendo doble clic, NO)

    Descargas el que se ajuste a tu equipo – versión

    abres terminal

    Vas al directorio donde está el archivo descargado (usualmente cd Descargas)

    luego, asegúrate que estas en el directorio correcto (ls)

    Si ves el paquete descargado tecleas sudo dpkg -i <nombre_de_paquete> e intro. Ya está!!!

  • #1841

    Mamenjg
    Member

    Pues lo estoy intentando y no hay forma. os envío captura de pantalla de lo que me sale. Muchas gracias

    Attachments:
    You must be logged in to view attached files.
  • #1845

    pedro.pena
    Member

    Hola,

    Debes usar el paquete debian de Firefox para tu distribución, no vale cualquiera. En tu caso parece que estás usando Max 6.0 que está basado en Ubuntu 10.04. Por lo tanto deberías usar el siguiente: https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa/+files/firefox_16.0.2%2Bbuild1-0ubuntu0.10.04.1_i386.deb

     

    Un saludo.

  • #1846

    jesusdeyarza
    Member

    Oscar y Pedro,

    mil gracias por vuestra paciencia con nuestra torpeza. 

    Oscar, siguiendo el hilo de vuestros consejos anteriores había intentado instalar el archivo desde la terminal, usando el comando cd descargas (pero lo hacía con “d” minúscula y claro, no encontraba la carpeta y por supuesto tampoco el archivo -no sabía que la terminal era tan sensible a las mayúsculas), por eso como un borrico lo volvía intentar cliqueando dos veces en el archivo descargado.

    Cambiando ese pequeño detalle he podido entrar en la carpeta e instalar el ff 16.02… y ya me funciona correctamente el exelearning…. ¡¡¡Mil gracias!!!

    Dejo este post para que nadie tropiece en la misma piedra.

    Un saludo a los dos

    Jesús

     

     

     

     

  • #1847

    jesusdeyarza
    Member

    Mi post iba para Antonio y Pedro (no sé porqué he puesto Oscar)

    gracias Antonio por insistirme con cd Descargas…

    de nuevo un saludo

    Jesús

  • #1848

    Jejejejeej, nada a ti. Pedro es el master!!!!!!

  • #2163

    apolo
    Member

    Hola a todos,

    – Hace unos días vi este hilo del foro y os comento que yo desde septiembre del 2011 solucioné el problema con firefox de por vida (bueno la nueva versión de exe ya no tendrá esa dependencia):

    – El problema comenzó al actualizar a firefox 3.5 pero actualmente trabajo con firefox 17.0.1 y mi exe sigue sin “quejarse”. ¿Por qué? pues porque mi exe lo tengo configurado para que use un firefox anterior. El proceso para linux es el siguiente:

    1. – Descargamos del sitio ftp://ftp.mozilla.org/pub/firefox/releases/ una versión anterior a la 3.5 para linux y en español.
    Por ejemplo la 3.0.14 ftp://ftp.mozilla.org/pub/firefox/releases/3.0.14/linux-i686/es-ES/firefox-3.0.14.tar.bz2

    2. – La descomprimimos por ejemplo en nuestro /home/usuario/firefox-3.0.14

    3.-  Abrimos nuestro /home/usuario y ponemos a ver los ocultos (por ejemplo pulsando Ctrl H).

    4.- Encontraremos una carpeta oculta de nombre  .exe

    5.- Aconsejo copiar la carpeta que hemos obtenido antes (firefox-3.0.14) dentro de esta carpeta  .exe   de esta forma aunque borremos la que pusimos en nuestro home no borraremos la que está en el oculto.

    6.- Dentro de esa carpeta /home/usuario/.exe vemos que hay un fichero de configuración exe.conf

    7.- Editamos  exe.conf 
    y donde pone   browserPath = firefox
    lo cambiamos por  browserPath = /home/usuario/.exe/firefox-3.0.14/firefox

    8. – Ahora ya podemos arrancar el exelearning.
     
    NOTA: si antes de hacer los cambios intentaste arrancar el exe y no pudo al tener un firefox más moderno tendrás que reiniciar el ordenador para que funcione el cambio explicado.
     
    A partir de ahora vuestro exe funcionará bien independientemente de la versión a que se esté actualizando firefox sin necesidad de hacer dowgrade ni cosas raras.
     

  • #2165

    Gracias Apolo:

    Seguro que le interesa y ayuda a mucha gente. Como bien dices, la siguiente versión ya no dará ese problema.

    Un saludo

  • #2171

    apolo
    Member

    Hola a todos,

    – Mi firefox en guadalinex 10.04 se acaba de actualizar de la versión 17.0.1 a la versión 18.

    – El 7-01-2013 puse en el hilo del foro una solución al arranque de exelearning y sigue funcionando mi exe perfectamente sin afectarle el que ahora tengo firefox 18.0

  • #2182

    abix_adamj
    Member

    Hy,

    I found this topic, because I was looking for problem with exe under Ubuntu 12.04. I see, that you don’t know how to downgrade firefox under Ubuntu. There are few steps to do:

     

    1. download  from: http://sourceforge.net/projects/ubuntuzilla/files/mozilla/apt/pool/main/f/firefox-mozilla-build/

    for i386 (32bit) – direct : http://sourceforge.net/projects/ubuntuzilla/files/mozilla/apt/pool/main/f/firefox-mozilla-build/firefox-mozilla-build_16.0.2-0ubuntu1_i386.deb/download

    In Terminal:

    sudo apt-get remove firefox

    sudo dpkg -i ~/Downloads/firefox-mozilla-build_16.0.2-0ubuntu1_i386.deb

    Or – right mouse click and “open in Software Center” or something like ….

     

  • #2183

    pedroruizf
    Member

    Parece que funciona con Firefox 18, os comento como lo he solucionado me he descargado el archivo .deb de exelearning de https://www.dropbox.com/s/c109gkuna9prvsw/python-exe_1.04.1.3605intef6.3_i386.deb en mi caso es de 32 bits.

    en un terminal y si me lo he descargado en la carpeta “Descargas” de un usuario llamado “usuario”.

    sudo dpkg -i /home/usuario/Descargas –force-depends python-exe_1.04.1.3605intef6.3_i386.deb

    con loos atributos –force-depends fuerzo a que no tenga en cuenta las dependencias que son Firefox 16 o menor.

    Y os repito parece que funciona sin problemas en ubuntu 12.04.1 32 bits.

    Por cierto me gustaría probar el nueve exe en ciernes para reportar errores, ¿Cómo puedo hacerlo?.

    Saludos.

  • #2184

    Hola Pedro:

    En esta semana abriremos un espacio para que quienes quieran se puedan apuntar al grupo de probadores. Mientras tanto te escribo mensaje por e mail para el contacto.

    Un saludo

  • #2213

    pedro
    Member

    Hola.

    Después de un intento hace mes y medio, que acabó en fracaso, hoy lo he vuelto a intentar y me he dado cuenta de lo burro que soy a veces. No me voy a extender. El caso es que he conseguido instalar firefox 16.2 y exe-learning ha funcionado, pero después he visto la solución de Apolo y he decidido probarla. También ha funcionado. 

    Me ha costado un poco, después de tener todo instalado, al actualizar a firefox 18.0  el synaptic me ha desinstalado python-exe y lo he tenido que volver a instalar con el terminal dpkg -i (para mi la consola es toda una proeza).

    Ahora tengo firefox 18.0 y exelearning funcionando con firefox16.02. Me parece una solución muy interesante para no tener que estar vigilando cuando entran las actualizaciones de firefox, que es lo que hago con el portatil pequeño, que era mi último recurso en estos dos meses.

    Muchas gracias a todos.

     

    • This reply was modified 7 years, 8 months ago by  pedro.
  • #2562

    fmartagong
    Member

    Hola a todos:

     

    A ver si me podéis echar una mano porque me encuentro en un callejón sin salida. Trabajo en el IEDA y como sabréis no es recomendable que usemos versiones posteriores a la 6.2

    En casa trabajo con Ubuntu 11.10 64 bits y tengo problemas desde que se actualizó Firefox a la versión 17. Primero intenté desinstalar Firefox e instalar la versión 16, con dpkg, pero de esta manera eXelearning no arranca (ya probé reiniciar). Luego he intentado la opción de instalarlo en el espacio de usuario y cambiar la ruta de configuración de eXelearning, pero entonces tengo el problema de que cuando abro elps me aparece el error “Sorry, wrong file format“.

    Me suena que este problema ya lo padecí antes y hubo que arreglarlo, pero no recuerdo cómo.

    Tampoco me queda claro por qué si el problema ha surgido con la actualización de Firefox, al dejar de usar éste una determinada función, ¿a qué se debe que falle en linux y no en Windows?

     

    Y ya aprovechando, aunque me vaya del hilo ¿cómo de lejos queda solucionar los problemas de compatibilidad de la intef7 con paquetes generados por versiones anteriores?

     

    Un saludo y gracias anticipadas.

  • #2564

    No existen problemas de compatibilidad con versiones anteriores. Se respeta la compatibilidad hacia atrás

    Si detectas alguno, sería interesante que lo reportaras.

    Trabajar con versiones anteriores a 6.2 … es absurdo con la intef7. Actualízate

  • #2581

    fmartagong
    Member

    Hola Antonio:

    Esa no es la información que tenemos, y el hecho es que la versión 6.2 no es capaz de abrir elps creados con versiones anteriores, por lo tanto la compatiblidad hacia atrás, desgraciadamente, no se está respetando, lo cual es un problema bastante serio para la comunidad de desarrolladores de Andalucía, porque tenemos muchísimo material creado con esas versiones.

    Ya he resuelto el problema, ¿qué he hecho? simplemente me había equivocado de versión, instalando la 6 ya puedo abrir los elps. Fíjate, la compatibilidad hacia atrás no funciona ni siquiera entre la 6 y la 6.2

    Soy un humilde aficionado y de programación sé muy poco, pero creo que esto no debería ser así.

    Tampoco sé cuánta gente está desarrollando materiales con eXeLearning, pero intuyo que la comunidad del IEDA es una de las más activas en este sentido, sin embargo no podemos pasar de la versión 6 cuando ya vais por la intef7.

    Creo que algo no se está haciendo bien. Como mínimo se debería crear un filtro para poder importar un elp “antiguo”.

    Mientras tanto tendremos que seguir, parafraseándote, Antonio, absurdamente con la versión 6.

     

    Un saludo y gracias.

     

    Pd.: Subo un elp creado con la versión 6 (creo, porque algunas versiones no están bien empaquetadas y no muestran la revisión, eso provocó mi error) y que da el mensaje de

    Sorry, wrong file format“ cuando intenta abrirse. Envío éste pero lo mismo ocurre con cualquiera.

    Attachments:
    You must be logged in to view attached files.
  • #2585

    Hola fmartagong:

    Gracias por el archivo. Lo he abierto borrando los archivos content.xml y content.xsd.

    Miramos el error que se da y las razones. Te adjunto el fichero para ver si lo puedes abrir con la nueva.

    Estaría bien que pudiéseis colaborar con estas detecciones de errores porque quedaros en la versión 6 va a ser penoso. Nosotros estamos dispuestos a solucionarlo ¿estaríais dispuestos a testear las soluciones? A quien corresponda, claro

    Un saludo

    Attachments:
    You must be logged in to view attached files.
  • #2601

    fmartagong
    Member

    Hola Antonio:

    Encantado echo una mano, pero no sé si soy la persona más indicada. Como sabrás nuestro material debe subirse a Agrega y desconozco si un archivo que yo teste a nivel que manejo de la aplicación va a cumplir luego los requisitos para que valide en Agrega.

    Otra cosa que quiero dejar clara es que he participado por resolver un problema que me afectaba en la productividad de mi trabajo, no soy programador y sólo escribo a título personal, así que si no es adecuado que participe en el foro no quiero estar donde no me corresponde.

    Esta tarde abro el archivo en Ubuntu, en el trabajo por desgracia tengo que usar Windows.

    Un saludo y gracias.

  • #2602

    Hola fmartagong:

    Tu ayuda a servido de MUCHO y hemos podido solucionar cosas que no estaban funcionando. Nuestro objetivo es que cualquier exportado valide y publique en agrega así que cualquier defecto en este sentido es prioritario.

    El foro es abierto por lo que siempre serás bienvenido

    Muchas gracias

You must be logged in to reply to this topic.