SCORM export in Moodle does not save progress

Home Forums Ayuda / Ajuda / Laguntza / Axuda / Help SCORM export in Moodle does not save progress

This topic contains 11 replies, has 5 voices, and was last updated by  Ignacio Gros 1 week, 6 days ago.

  • Author
    Posts
  • #35205

    Cleo
    Member

    Hello,

    I have the following problem: when I export via SCORM and import the file in Moodle, the student’s progress is not tracked. Even though the students complete the lecture, the checks are not in place, see attached file.

    Is there a way to solve this?

    Attachments:
    You must be logged in to view attached files.
  • #35229

    Ignacio Gros
    Member

    Use SCORM 1.2 instead of 2004 (enable the “Advanced mode” to show that option). But it won’t work in the latest versions of Google Chrome because of this change in the default browser configuration. Related issue in GitHub.

  • #35239

    TomiStyle
    Member

    Entiendo que usando Chrome entonces no vamos a poder seguir el progreso de los alumnos?
    He probado con el nuevo Edge y le pasa lo mismo.
    Si que es cierto que algunos nodos si me los marca, no en directo, pero si al volver a entrar en el scorm…
    Probando con IE si que los va marcando en directo, pero claro… cualquier usa IE hoy en día…
    Hay alguna solución??
    A unas malas supongo que será poner que se marca como finalizada la actividad en moodle si acceden, pero es una pena.

  • #35242

    guzmangr
    Member

    Lo estoy probando y todos mis trabajos eXe no funcionan tampoco en moodle. ¿No hay ninguna solución?

  • #35395

    TomiStyle
    Member

    Alguna solución??

    • #35397

      Ignacio Gros
      Member

      Pasa en las últimas versiones de Chrome y otros navegadores basados en Chromium. Con Firefox, por ejemplo, no te pasará. Al parecer, con una actualización de Moodle (o aplicando un parche a la instalación) se soluciona, pero aún no he podido probarlo. Más información: sobre el fallo, sobre la solución en Moodle. De momento no hay solución rápida vía eXe.

  • #35413

    Hola, ayer actualicé mi versión de eXe porque con la anterior (2.1) al exportar a Scorm i cargarlo en el aula Moodle, cuando había un subtítulo se quedaba parado, pero en la versión actual hace lo mismo. Me pasa tanto en Chrome como en Firefox. Por favor ¿podéis indiarme que debo hacer para que funcione bien? Muchas gracias
    Gemma

    • This reply was modified 2 weeks, 6 days ago by  Gemma Vallès.
    • #35415

      Ignacio Gros
      Member

      Hola Gemma. No sé si he entendido bien el problema. Tal vez se deba a la versión de SCORM usada. Prueba exportando como SCORM 1.2 (activa la casilla “Modo avanzado” para ver la opción”). ¿Resuelve eso el problema? Si no es así, ¿puedes dar algún detalle más?

  • #35426

    Hola Ignacio,
    La versión que tengo instalada es la 2.5, he ido a Modo avanzado y exportado como Scorm 1.2 como me comantas, pero al subirlo al campus Moodle i abrirlo, funciona correctamente hasta que llegas al primer titulo que tiene subtitulos, se queda parado y ya no sigue adelante. Te adjunto una imagen para que puedas verlo mejor.
    ¿qué puedo hacer?
    Muchisimas gracias por tu ayuda.
    Saludos
    Gemma

    Attachments:
    You must be logged in to view attached files.
    • #35450

      Ignacio Gros
      Member

      Si el fallo se produce en Moodle con Chrome, es posible que se deba a esto. Si no, adjunta el SCORM o mándalo a la dirección que aparece a pie de página y lo probamos. O, si puedes, danos acceso al curso. A ver si hay suerte y damos con el problema.

  • #35471

    Gracias Ignacio. Lo he probado también con Firefox y da el mismo problema.Te adjunto el SCORM por si veis alguna cosa que no hago correctamente.
    Saludos
    Gemma

    Attachments:
    You must be logged in to view attached files.
    • #35476

      Ignacio Gros
      Member

      Gracias, Gemma. Hemos visto que funciona si usas el menú, pero falla con las páginas anidadas cuando usas los botones de anterior/siguiente de la parte inferior. No sé si será fallo del visor de Moodle o de eXe. Abrimos incidencia para intentar resolverlo.

You must be logged in to reply to this topic.