Navigation and Bookmark not working with SCORM

Home Forums Ayuda / Ajuda / Laguntza / Axuda / Help Navigation and Bookmark not working with SCORM

This topic contains 31 replies, has 10 voices, and was last updated by  andres.campos 2 months ago.

  • Author
    Posts
  • #34089

    jay.jeet
    Member

    <p>Hi,</p><p>I am using eXeLearning for e-learning content creation and it worked very well. I am facing navgiation and bookmark related issue with exported SCORM package.<br />I have exported SCORM with both types for e.g. SCORM1.2 and SCORM2004 and for both navigation and bookmark feature is not enabled in my production LMS ‘Opigno’.<br />However I found that navigation works properly with out any issue in ‘Moodle’ instance.<br />Kindly let me know if I have to enable any additional setting to enable navigation and bookmark in SCORM package to work with any other LMS than ‘Moodle’.</p><p>Thanks a lot.</p>

  • #34101

    Ignacio Gros
    Member

    Hi,
    eXe generates valid SCORM packages (1.2 or 2004). They should work in any LMS that supports them. It there’s any problem, we could check it if you provide a link to see the published content. Thank you.

  • #34105

    jay.jeet
    Member

    <p>Hi Ignacio,</p><p>Thanks for quick response. Because of security reason I may not be able to provide you the direct link of published content. However if convenient with you we can set up the Webex as per your convenience. Kindly let me know if that works with you.</p><p>Really appreciate your support.</p>

    • #34106

      Ignacio Gros
      Member

      Could you send a link + user and password (if needed) to the address in the page footer? We can’t set up a meeting for support these days. Sorry…

  • #34147

    jay.jeet
    Member

    <p>GM Ignacio,</p><p>Thanks for your response. As mentioned earlier I will not be able to provide an access to LMS due to security issues, but I will find a way out to share the exported SCORM package with you for investigation.</p>

  • #34235

    jay.jeet
    Member

    <p>Hi Ignacio,</p><p>I have received the permission to share the published SCORM package with you. Please share your mail address so that I can mail you the package. Note the size is 25mb.</p>

  • #34244

    jay.jeet
    Member

    <p>GM Ignacio, Meanwhile I have created a sample SCORM and attached for your reference. Kindly look in to this and let me know if navigation works for you. Thanks a lot for your assistance.  </p>

    Archivos adjuntos:
    You must be logged in to view attached files.
  • #34256

    Ignacio Gros
    Member

    Hi,
    It tried SCORM 1.2 and 2004.
    As you said, they work in Moodle, but not in Opigno, because it doesn’t display any navigation options (no menu, no Next/Previous buttons). I think that it doesn’t have any option for that. At least I couldn’t find it.
    “Web Site” is the only export that includes a navigation menu. Maybe you can use that, but you’ll have to include some files (imsmanifest.xml) in order to publish the content, and the result won’t be a valid SCORM package. The LMS won’t be able to get the activity properly.
    Any internal links will be removed when exporting, so you can’t use the “Add link to node” option. You can manually add a link to other pages knowing the name of each HTML file. Example: <a href="topic1.html">Next</a>
    But for the SCORM files generated by eXe, the navigation should be provided by the LMS, and it’s not in Opigno. Maybe that LMS is only expecting single page SCORM packages, or packages that provide its own navigation menu.

    • This reply was modified 4 months, 1 week ago by  Ignacio Gros. Reason: Complete the answer
  • #34272

    Jose-C
    Member

    <p>Hola Ignacio, a mi me pasa algo parecido pero con moodle. Dentro del SCORM no se marcan los apartados como visualizados al ir navegando por los diferentes temas que haya dentro del SCORM, lo curioso es que esto solo ocurre con Google Chrome, he probado en varios ordenadores y siempre ocurre igual.</p><p>Sin embargo, he probado en otros navegadores como Edge o Firefox y funciona todo correctamente.</p><p>Sabes si hay alguna forma de solucionar esto?</p><p>Muchas gracias.</p>

    • #34274

      Ignacio Gros
      Member

      ¿Has probado con SCORM 1.2? Activa el modo avanzado para exportar en ese formato. Con Moodle hay más problemas con 2004 (por Moodle). Si falla con 1.2, hacemos pruebas con Chrome. Gracias por el aviso.

    • #34277

      Jose-C
      Member

      <p>Si claro, siempre exporto en 1.2, pero sigue fallando… Hace unos meses me pasaba también pero lo solucioné cambiando el estilo del scorm… Pero ahora he probado la misma estrategia y falla con todos…</p><p>Gracias por la respuesta</p>

    • #34311

      Ignacio Gros
      Member

      Gracias a ti. Abrimos incidencia e intentamos solucionarlo.

    • #34439

      exelearning
      Member

      El fallo se produce por un cambio en la configuración por defecto del navegador (Google Chrome). Si habilitas AllowSyncXHRInPageDismissal (ve a chrome://flags/ con ese navegador y busca allow-sync-xhr-in-page-dismissal), la información se guarda correctamente. Seguiremos buscando una solución de cara a la próxima versión. Muchas gracias por el aviso.

      Más información en https://chromestatus.com/feature/4664843055398912

    • #34954

      Gracias, me funcionó esta solución.
      Un saludo

  • #34299

    JC
    Member

    <p>Buenos días.</p><p>A mí también me pasa lo mismo con cualquier tema. Lo curioso es que en la captura que anexo se marcan los dos primeros y el resto no.</p><p>Un saludo.</p>

    Archivos adjuntos:
    You must be logged in to view attached files.
  • #34303

    jay.jeet
    Member

    <p>Hello Ignacio,</p><p>I tried to enable the navigation controls available under the advance setting in properties. Now the ‘Previous/Next’ links are shown in the course but they are not active. My LMS is ‘OPIGNO’. I read your comments about these settings where you mentioned it works only for Moodle LMS and not fir other LMS. Is it still the case ?.</p><p>Regards,</p><p>Jay Suryavanshi.</p>

    • #34310

      Ignacio Gros
      Member

      > I tried to enable the navigation controls available under the advance setting in properties.

      Those controls won’t work. They’re not part of the standard and they only work with some LMS. They worked with old Moodle versions, like 1.9, but they’re not even working with newer Moodle versions. Maybe they should just not be in eXe any more.

  • #34343

    yrabassa
    Member

    <p>Hola Ignacio:</p><p>Tengo el mismo problema que los compañeros. El paquete scorm exportado (1.2) no muestra los controles de navegación, ni menús, una vez se ejecuta el LMS. He probado distintos estilos, distintos tamaños de elp, distintos navegadores, distintos sistemas operativos. El resultado siempre es el mismo.</p><p>Uso v2.5 y el LMS es NEO</p><p>Adjunto elp de prueba: https://www.dropbox.com/s/ppec0glwfwyo49j/O%C3%ADdo.elp?dl=0</p><p>Scorm exportado: https://www.dropbox.com/s/wvbks942a04dqqq/prueba%20o%C3%ADdo.zip?dl=0</p><p>Captura de Visualización previa: https://www.dropbox.com/s/51qxb63zstk5w62/Captura%20de%20pantalla%202020-05-28%20a%20las%2013.49.52.png?dl=0</p><p>Captura de visualización en LMS: https://www.dropbox.com/s/nrz49rzv1cqitya/Captura%20de%20pantalla%202020-05-28%20a%20las%2013.49.30.png?dl=0</p><p>Gracias de antemano!</p>

    • This reply was modified 4 months ago by  yrabassa.
    • #34372

      Ignacio Gros
      Member

      Hola:

      Con el usuario de pruebas no he podido gestionar el SCORM, pero en la pestaña “Opciones” veo esto:

      Navegación: Outline
      Reproducción automática? Sí

      Tal vez modificando esos valores muestre las opciones de navegación y se comporte de la manera esperada. Si no hay opciones para modificarlos, es posible que el LMS no contemple esa opción. Con rol de administrador podría probarlo, pero la prueba que haría sería esa.

    • #34374

      yrabassa
      Member

      <p>Gracias Ignacio:</p><p>Esas pruebas ya las hice antes de contactar por aquí, y nada, no produce cambios de ningún tipo.</p><p>Como digo, tengo otros muchos cursos en este mismo LMS, hechos con ExeLearning, y mismo estilo de diseño que sí funcionan correctamente. La única diferencia es que todos los demás se hicieron con versiones anteriores de Exe</p>

    • #34375

      Ignacio Gros
      Member

      Gracias a ti. Incluyo tu comentario sobre las versiones previas de eXe en la incidencia relacionada por si se hubiera realizado algún cambio en la última versión.

  • #34345

    Ignacio Gros
    Member

    NEO sólo ofrece soporte SCORM en su versión de pago, y no tengo acceso a ella. Si quieres que probemos, necesitamos verlo en el LMS. Podrías enviar los datos de acceso a la dirección que aparece a pie de página. De todas formas, si NEO no pinta el menú y/o los botones de Anterior/Siguiente, y no ofrece una opción de configuración para que lo haga, de momento no podremos hacer nada desde eXe.

  • #34347

    yrabassa
    Member

    <p>Gracias por la respuesta!</p><p>Os he enviado al email los datos de acceso a NEO para probar.</p><p>En todo caso, tengo otros cursos en NEO desde hace algunos años, y lo único que ha cambiado entre este último paquete Scorm que no muestra botones de navegación ni menús, y los que sí lo muestran en NEO, es la versión de EXE (los primeros paquetes se hicieron con dos versiones anteriores, y este último al que accedéis y que da problemas con la 2.5). El estilo también es el mismo.</p><p>Es por ello que sospecho pudiera tratarse de un problema de la versión reciente.</p>

  • #34348

    <p>Hola Tengo el mismo problema de que no marca la actividad como terminada, yo exporto a Zip HTML por que ahi si veo los controles de navegación, si lo exporto en cualquier de los dos formatos de SCORM, cuando lo integro en mi LMS me aparece el error “Cannot GET /doc/sngNBzjmAG/null” ¿quisiera saber si hay alguna sentencia en HTML o java Script que pudiera agregar a un botón que le indique a mi LMS que ya terminó la actividad? o como puedo visualizar mi paquete SCORM sin que aparesca el error que adjunte hace un momento</p><p>Adjunto mi proyecto de eXe</p>

    Archivos adjuntos:
    You must be logged in to view attached files.
    • #34373

      Ignacio Gros
      Member

      Si el LMS soporta SCORM 1.2 o 2004, debe registrar la actividad (hasta cierto punto, porque las calificaciones sólo se guardan en algunos iDevices: GeoGebra, SCORM, iDevices de la categoría Experimental). No debería ser necesario incluir ninguna sentencia adicional.

      Lo de que no aparezca el menú más que en los sitios web es normal. Es la única exportación que lo incluye. En el caso de publicación de SCORM en el LMS, será este último el que genere el menú partiendo de los datos incluidos en el paquete SCORM (están en un fichero XML).

  • #34377

    <p>Muchas gracias Ignacio por tu respuesta, referente al error que me presenta cuando trato de visualizar el paquete scorm en mi LMS ( “Cannot GET /doc/sngNBzjmAG/null”), ¿tendrá que ver que puse un IDivace de texto con código de HTML incrustado por mi y un javaScript en un botón?</p><p>adicionalmente ¿si quisiera exportarlo como sitio web hay alguna sentencia que pueda usar para indicarle al LMS que la actividad ya termino?</p><p>Muchas gracias por tu amable ayuda</p><p>Saludos cordiales</p><p> </p><p> </p>

    • #34382

      Ignacio Gros
      Member

      1. Un código HTML o JavaScript no debería producir un fallo así, salvo que haya un fallo en el JS que impida la carga de la página, pero un error así, es raro. Puedo probar si me envías el SCORM.

      2. Algunos iDevices (como actividad SCORM) permiten pasar ese tipo de información al LMS (la calificación). En los demás casos, lo único que se registra es si la página se ha visto.

  • #34393

    OK adjunto el paquete SCORM y tambien el proyecto para ver si me pudieras ayudar si tiene un error muchas gracias por tu amable ayuda

    Archivos adjuntos:
    You must be logged in to view attached files.
    • #34409

      Ignacio Gros
      Member

      En la página de inicio hay un fallo en una imagen (no existe). Tal vez ese sea el problema. Edita el elp para corregir el problema. La imagen es Liderazgo_Dulce_Fast.png

      El la última página hay un fallo de JavaScript (document.fvalida.C1), pero no creo que ese sea el problema.

  • #34481

    Thanks for the solution.

  • #34765

    magnulu
    Member

    What was the solution? 🙂

    I also have the issue with our LMS (not Moodle) not showing any menu or navigation links, but as far as I understand from Ignacias answer above, this is the expected behaviour?

    As a workaround, the LMS provider is hosting the exported course as a self contained web page, and we put that in a page in the course in the LMS. It does not give the 100% experience I am wishing for, but still works kind of..

    If some of you want to test the scorm issue, I can provide access to our LMS in a private message.

    Thanks in advance,

    -Magnus

    • This reply was modified 2 months, 2 weeks ago by  magnulu. Reason: added information
    • This reply was modified 2 months, 2 weeks ago by  magnulu. Reason: added link to post mentioned
    • #34826

      Ignacio Gros
      Member

      Hi Magnus,
      Thanks for sharing that workaround. Unfortunately, there’s no fast solution for that issue. If the browser does not allow the beforeunload handler any more, we need to find another way to do that, but those changes have to be done in eXe’s files.

You must be logged in to reply to this topic.