Need Help

This topic contains 2 respuestas, has 2 voices, and was last updated by  Ignacio Gros Hace 10 meses.

  • Author
    Entradas
  • #39478

    Anónimo

    Dear all, we are using EXE with Arabic language and are facing problems that affect the setting of the bullets (radio buttons and selection boxes) in all idevices whereas the Arabic text is right justified and the buttons and selection boxes are left justified.
    Another problem is the Arabic font in the scrambled list idevice that is not available in different sizes so we had to improvise by adding html code to have a different size.
    Also for the button texts at the bottom of the scrambled text idevice, as well as the feedback fields, we tried entering the html code we used as in pict1 but once we save the scrambled list the code vanishes and does not give the desired size…
    Can you provide us with information how to edit the idevice so we can have something easier to modify and not to enter html codes every time? and how to edit the button text and the feeback fields?
    Thank you in advance and we hope you can help us…
    Ramzi Ataya – Beirut – Lebanon
    Email: ramziataya@yahoo.com

  • #39487

    Ignacio Gros
    Keymaster

    Hi,

    eXe has no RTL support out of the box.

    I think that the easiest way to do that is creating a new Style (Advanced mode – Style – Style manager – Create new style) and add the required CSS code in the Advanced tab (content.css block). Example:

    .iDevice_content{text-align:right;direction:rtl}

    You can also use more specific definitions, like:

    .ScrambledListIdevice li{text-align:right}

    If you prefer to include the CSS in the elp file instead of using a new style, you can use Advanced mode – Properties tab – Advanced Options – Custom HEAD. Example:

    <style>
    .iDevice_content{text-align:right;direction:rtl}
    </style>

    I hope it helps.

  • #39498

    Ignacio Gros
    Keymaster

    Just add this line to your CSS code:

    .iDevice_answer-field{float:right;text-align:right}

You must be logged in to reply to this topic.